Real Time Prescription Benefit — Intermittent Connectivity Issues

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 14:52 EDT

Investigating

We are aware of intermittent connectivity issues affecting real-time benefit checks originating with a third-party data provider. DrFirst systems are operating normally, and we are actively monitoring the situation.

In a small number of cases, partners may experience delayed or failed real-time benefit responses during this time. We will provide updates as more information becomes available.
Posted Jun 08, 2026 - 18:31 EDT
This incident affected: Total Benefits (Provider Solutions) (Price Transparency (mBC)).