DrFirst Notification - Messaging (Chat) service will be unavailable on 3/5/2026 from 3:30 PM to 5:00 PM ET for a mandatory company meeting

Scheduled for Mar 5, 15:30 - 17:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 04, 2026 - 12:08 EST

Scheduled

Messaging (Chat) service will be unavailable on Thursday, 3/5/2026 from 3:30 PM to 5:00 PM ET for a mandatory company meeting.

During this time, please submit a request at:

DrFirst US Support Services - https://help.drfirst.com/hc/en-us/requests/new
iPrescribe Support Services - https://help.iprescribe.com/hc/en-us/requests/new
Posted Mar 03, 2026 - 17:06 EST
This scheduled maintenance affects: DrFirst US Support Services (DrFirst US Live Messaging/Chat) and iPrescribe Support Services (iPrescribe Live Messaging/Chat).