Intermittent Performance Issues with Multiple Products

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 12:18 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 02, 2025 - 12:12 EDT

Investigating

We are currently experiencing intermittent performance issues across multiple products due to an ISP (Internet Service Provider) service disruption. Our engineering team is actively working with the provider to restore full service. We will provide updates as more information becomes available.
Posted Oct 02, 2025 - 11:49 EDT
This incident affected: E-Prescribing Desktop (Rcopia) (E-Prescribing Desktop Region 1 (Rcopia), E-Prescribing Desktop Region 2 (Rcopia), E-Prescribing Desktop Region 3 (Rcopia), E-Prescribing Desktop Region 4 (Rcopia), E-Prescribing Desktop Region 5 (Rcopia), E-Prescribing Desktop Staging Environment (Rcopia Staging Environment)), Third-Party Vendor Services (EPCS IDP (Experian/ID.me), PDMP, InfinID, Pharmacy Network - Prescribing, Pharmacy Network - Medication History (US)), and Electronic Prescribing for Controlled Substances (EPCS), E-Prescribing Mobile (iPrescribe), Medication History (MedHx).