Medication History (MedHx) Application Performance Issues

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 10:34 EDT

Investigating

We are experiencing performance issues with our Medication History (MedHx) applications that is resulting in slowness and technical difficulties serving eligibility and medication history requests.

Impact:
Slower response times for eligibility requests
Delays in medication history retrieval
Some requests may have timed out or failed

We apologize for any service disruptions and will provide updates as we have more information to share.
Posted Aug 20, 2025 - 09:59 EDT
This incident affected: Medication History (MedHx).