Intermittent Performance Issues - EPCS IDP (Experian/ID.me)

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 14:02 EDT

Investigating

IDP is currently experiencing an issue, which may affect your ability to authenticate or access services through the IDP. We are working with our 3rd Party vendor to resolve this as quickly as possible
Posted Oct 03, 2025 - 17:36 EDT
This incident affected: Third-Party Vendor Services (EPCS IDP (Experian/ID.me)).