Intermittent Performance Issues with MedHx email delivery

Incident Report for DrFirst

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 15:43 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 15:17 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 15:12 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 14:49 EDT

Investigating

We are currently experiencing email delivery delays that may impact users attempting to access the MedHx Companion application—particularly those waiting for login or verification emails.

Our team is actively investigating the issue and working with the email services to restore normal delivery times as quickly as possible
Posted Mar 24, 2025 - 14:29 EDT
This incident affected: MedHx.