PDMP Third-Party Incident for Illinois
Incident Report for DrFirst
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 23:02 EDT
Update
Customers may experience issues accessing Patient Searches via PDMP reports for the state Illinois. We are working with our partner and will keep this page updated.
Posted Apr 17, 2024 - 16:44 EDT
Update
Customers may experience issues accessing Patient Searches via PDMP reports for the state Illinois. We are working with our partner and will keep this page updated.
Posted Apr 17, 2024 - 14:05 EDT
Investigating
Customers may experience issues accessing Patient Searches via PDMP reports for the state Illinois. We are working with our partner and will keep this page updated.
Posted Apr 17, 2024 - 13:45 EDT
This incident affected: Third-Party Vendor Services (PDMP).